Slow starting

Help Support Early Bay Forum:

roybird

Member
Joined
Jan 9, 2019
Messages
7
Reaction score
0
I have a 72 crossover with recon engine and most things new, but takes a long time to start, once running is OK and will restart, feels like it needs a choke
 

roybird

Member
Joined
Jan 9, 2019
Messages
7
Reaction score
0
Hi
Spins well, battery is good
Just before it eventually fires up it will cough a bit, then I have to catch it
I’ve had different comments about pressing the throttle, but I still do so
The engine is sound and been on rolling road, the only changes have been E10 fuel and pancake filter, although the latter was fitted before the RR
 

sunnyside

Member
Joined
Nov 20, 2019
Messages
20
Reaction score
7
The choke could be sticking in the fully open position. I had an empi carb that had this problem so every time I wanted to restart it from cold I had to open the engine lid and push the stepped cam back to free it off.
 

Graham L

Well-known member
Joined
Jan 19, 2008
Messages
5,180
Reaction score
83
Location
Redditch
Is it a still on the original carb with automatic choke?
If it is are you allowing the choke to engage before starting the engine?, in order to do this you need to turn the ignition on, 2 warning lights on your dash, press the throttle pedal down to release the choke mechanism and then release it, then turn the key to crank it, if you don't do this it doesnt set the choke.

Hope that helps, if you have aftermarket twin carbs then they usually don't have chokes fitted so can take longer to start from cold.
 

Latest posts

Top